• Christopher Elías

    Christopher Elías

    1 year ago
    Hello guys, does anyone having this problem? I just open my project, and cant build because of this. I thinks is an IDE problem becuase when I run
    gradlew clean & gradlew assembleDebug
    from any terminal it executes without a problem
    Christopher Elías
    2 replies
    Copy to Clipboard
  • Brady Aiello

    Brady Aiello

    1 year ago
    Just upgraded to Arctic Fox, changed my
    JAVA_HOME
    to 11, made sure AS is using 11 as the runtime, and tried changing it gradle.properties as well, and I'm still getting this:
    > Failed to apply plugin 'com.android.internal.application'.
    > Android Gradle plugin requires Java 11 to run. You are currently using Java 1.8.
    You can try some of the following options:
    - changing the IDE settings.
    - changing the JAVA_HOME environment variable.
    - changing `org.gradle.java.home` in `gradle.properties`.
    I can build just fine from the terminal. Anyone solve this issue?
    Brady Aiello
    1 replies
    Copy to Clipboard
  • k

    Kenneth Leong

    1 year ago
    hi, I am not sure if its an Android studio issue or an intellij issue or even a gradle issue, i converted my groovy gradle build scripts to kotlin gradle dsl,  but now in my gradle tool window, i do not see any gradle tasks, only the dependencies of each module are shown. is this expected? Running 
    ./gradlew tasks
     i am able to see the list of tasks for my project though. I mm currently using gradle 6.5 with android studio 4.1.1, kotlin version 1.4.21
    k
    Shabinder Singh
    2 replies
    Copy to Clipboard
  • Rafs

    Rafs

    1 year ago
    Is there anyway of using similar keyboard shortcuts on android studio without having to manually edit all of them one after the other?
    Rafs
    Giorgos Neokleous
    2 replies
    Copy to Clipboard
  • WukongRework.exe

    WukongRework.exe

    1 year ago
    Android Studio won't recognize my language version is 1.4 and the compileKotlin block errors in gradle. I am trying to do a non-suspending lambda conversion to a suspend lambda without marking the function as suspend
    WukongRework.exe
    Javier
    10 replies
    Copy to Clipboard
  • Javier

    Javier

    1 year ago
    Someone is having problems related to run some Gradle tasks in Android Studio terminal, for example, having a failing test, run gradlew test, it fails, fix the test, run again gradlew test and it is like it is cached somewhere and it is reusing the previous code so it fails? I have to restart the IDE to fix this problem.
    Javier
    andylamax
    +1
    4 replies
    Copy to Clipboard
  • Yashar

    Yashar

    1 year ago
    Just realized that IntelliJ now supports the Apple silicone. Do we have a good timeline of when the AS would support it as well?
    Yashar
    s
    +2
    14 replies
    Copy to Clipboard
  • František Comorek

    František Comorek

    1 year ago
    Hello, I am new to android studio. Experimenting with Kotlin Multiplatform Mobile. When I try to run iOS simulator I get following error:
    Unsupported Xcode version 10.1, minimal supported version is 11.0.
    Is there a way how to set up the android studio to use lower Xcode version? Updating Xcode is not an option for me.
    František Comorek
    Umar Ata
    5 replies
    Copy to Clipboard
  • l

    Lilly

    1 year ago
    Hi, Android Studio does not recognize my device while calling
    adb devices
    does. I tried the common troubleshooting but nothing helped. Does someone have an idea?
    l
    Larry Schiefer
    2 replies
    Copy to Clipboard
  • Roar Gronmo

    Roar Gronmo

    1 year ago
    NOTE!! Please be careful after updating AS2020.3.1.x to AS2020.3.1.5 and want to install the suggested Kotlin update (1.4.21 to 1.4.30 RC IJ"somewhat"), it rendered the shared 2020.3 store unusable, and you get this "Missing essential plugin: org.jetbrains.android Please reinstall Android Studio from scratch". It won't help. You need to delete (or at least rename) the path "C:\Users[your_user_name]\AppData\Local\Google\AndroidStudioPreview2020.3" before you do any installation. Do NOT copy your settings from there when you install from scratch (you just inherit the errors). You need to rebuild your settings, (if you haven't exported your settings sometimes) (as i didn't)... The kotlin plugin seems the one to blaim. I strongly eager AS/IJ engeneers to make a "repair" tool when this type of errors plugin related errors occures.
    Roar Gronmo
    3 replies
    Copy to Clipboard