• Zach Klippenstein (he/him) [MOD]

    Zach Klippenstein (he/him) [MOD]

    2 years ago
    What’s the best way to block input and focus to a Composable? I don’t want it to draw with the disabled emphasis, just make it not interactive.
    Zach Klippenstein (he/him) [MOD]
    1 replies
    Copy to Clipboard
  • m

    molikto

    2 years ago
    On snapshot after the change to move to function-body-based code generation strategy, my project now triggers some compiler exception (getParent is null). Is there a way to debug where it is triggered?
    m
    l
    6 replies
    Copy to Clipboard
  • manueldidonna

    manueldidonna

    2 years ago
    I'm having some trouble on limiting the number of chars of a TextFieldValue.
    var selection by state { TextRange(0, 0) }
    var text by state { repository.getText() }
    TextField(
        value = TextFieldValue(text, selection),
        onValueChange = { 
            selection = it.selection
            // there is a a limit on the number of chars. 
            // The passed text is automatically truncated
            text = repository.updateText(it.text) 
        }
    )
    When I exceed the number of chars, I have some problems with the keyboard that continues to record the inputs, so I have to press the delete button more times than needed.
    manueldidonna
    l
    2 replies
    Copy to Clipboard
  • s

    Socheat KHAUV

    2 years ago
    ContextAmbient.current is not available, is there alternative way to get current Context ?
    s
    l
    +2
    7 replies
    Copy to Clipboard
  • Klaas Kabini

    Klaas Kabini

    2 years ago
    @Mihai Popa As I was checking as list of commits you guys made on compose branch. I saw a commit that says updating compose to 0.1.0-dev14 but has not seen the one that says updating compose to 0.1.0-dev13. Was this done intentional jumping from 0.1.0-dev12 straight to 0.1.0-dev14?
    Klaas Kabini
    John O'Reilly
    3 replies
    Copy to Clipboard
  • pavi2410

    pavi2410

    2 years ago
    I don't know why it's not building. I just updated AS to canary 9. This was showing that the bundled Kotlin library is old, so I updated it to 1.3.72. Now, it says that it differs with the bundled version. Also, the Compose plugin is incompatible
    pavi2410
    m
    3 replies
    Copy to Clipboard
  • p

    pardom

    2 years ago
    What's the best way to add a header to an
    AdapterList
    ? Can it be nested in a
    VerticalScroller
    ?
    p
    Adam Powell
    3 replies
    Copy to Clipboard
  • k

    Kazemihabib1996

    2 years ago
    What's the equal of textView.setText(
    (Html.fromHtml(htmlString , Html.FROM_HTML_MODE_LEGACY)));
    in compose?
    k
    Adam Powell
    +1
    11 replies
    Copy to Clipboard
  • camkadev

    camkadev

    2 years ago
    also in
    dev11
    it’s impossible to extend
    Brush
    class with message
    '<init>': it is private in 'Brush'
    camkadev
    k
    2 replies
    Copy to Clipboard
  • carbaj0

    carbaj0

    2 years ago
    what is the better approach to applying a margin to a component (FilledTextField for example)?
    carbaj0
    2 replies
    Copy to Clipboard