• rkeazor

    rkeazor

    4 years ago
    Is there any support for making network request with a multiplatform kotlin project
    rkeazor
    s
    +4
    8 replies
    Copy to Clipboard
  • josephivie

    josephivie

    4 years ago
    I'm constructing a temporary Gradle plugin for using reflection across all platforms. Basically, it reads your code and creates KClass implementations for everything explicitly marked, which will be accessible through something like
    MyClass::class.full
    . Any suggestions/requests/interest?
    josephivie
    2 replies
    Copy to Clipboard
  • josephivie

    josephivie

    4 years ago
    <SOLVED> I'm having trouble getting Android Studio to recognize a module's dependencies (including the standard library) in my Gradle common project. It's odd - as far as I can tell, it's exactly the same as one of my other projects where that's all working great. Anybody have any helpful hints?
    josephivie
    5 replies
    Copy to Clipboard
  • d

    drofwarcs

    4 years ago
  • n

    napperley

    4 years ago
    How is a Kotlin multi-platform library distributed/deployed
    n
    josephivie
    5 replies
    Copy to Clipboard
  • a

    albertgao

    4 years ago
    Am I alone?
    expectedBy
    from
    kotlin-platform-android'
    seems to cause warning:
    Warning:Configuration ‘compile’ is obsolete and has been replaced withimplementationand ‘api’.
    It will be removed at the end of 2018. For more information see: <http://d.android.com/r/tools/update-dependency-configurations.html>
    Even though I don’t know which line causes the trouble, but this is the only possible line. Anyway to fix this? Or maybe from other dependencies…
    a
    ilya.gorbunov
    2 replies
    Copy to Clipboard
  • r

    robstoll

    4 years ago
    r
    1 replies
    Copy to Clipboard
  • p

    patjackson52

    4 years ago
    nm, this error happens with same code in plain jvm module. I get no errors in IDE though. This is going to be a tough one 🤦
    p
    1 replies
    Copy to Clipboard
  • b

    bissell

    4 years ago
    Is there some step I'm missing to get
    kotlin.test
    unit tests in a common module to run in IDEA? The green arrows show up and seem clickable, but when I click them I get an error
    No JDK specified
    . If I change the common module's SDK to the JDK they will run, but this gets overwritten on any Gradle reimport. Will attach some details in a thread.
    b
    11 replies
    Copy to Clipboard
  • y

    yusuf3000

    4 years ago
    Noob android developer here. I have my kotlin multiplatform project which is currently being used in an iOS project via the framework that is generated by konan. What do i do if i want to use this in an android app? Do i generate a jar file and put it in the host app?
    y
    russhwolf
    +1
    4 replies
    Copy to Clipboard