• s

    streetsofboston

    1 year ago
    In the IDE I get these red-lines/errors. Hsowever, it all builds and compiles without issue. My IDE is Android Studio 4.0.1, Kotlin 1.4.10, KMM Plugin 0.1.1 and 0.1.2 (tried both). I tried re-syncing gradle, re-build from scratch, invalidate caches & restart; all to no avial. Does anyone else see the same issue?
    s
    Kris Wong
    +3
    67 replies
    Copy to Clipboard
  • c

    chi

    1 year ago
    What's the best resource to share with someone who knows only Android or iOS but wants to get into KMP. (assuming the person is a senior on either Android or iOS)
    c
    1 replies
    Copy to Clipboard
  • f

    faogustavo

    1 year ago
    1. How does the sourceSets understand and resolve the “parent” dependency? Is it some naming convention from gradle?
    f
    russhwolf
    3 replies
    Copy to Clipboard
  • f

    faogustavo

    1 year ago
    2. How do I define that a module is jvm/native/js in the project architecture created by intellij? They are defined by some naming convention too?
    f
    mbonnin
    2 replies
    Copy to Clipboard
  • f

    faogustavo

    1 year ago
    3. Is the default project architecture created by intellij good? Or is it better to create a “blank” project and add modules manually?
    f
    mbonnin
    6 replies
    Copy to Clipboard
  • John O'Reilly

    John O'Reilly

    1 year ago
    Is there particular pattern recommended for calling Kotlin method from Swift where that method in turns
    collects
    values from some
    flow
    source (e.g. db)
    John O'Reilly
    ankushg
    5 replies
    Copy to Clipboard
  • k

    KamilH

    1 year ago
    I’m trying to build Multiplatform library, I used a template “Mobile Library” from IntelliJ, implemented some basic stuff, added
    cocoapods
    plugin with some basic configuration. Then I built a project next I used
    podBuildDependenciesIos
    . Podspec files has been generated properly along framework. Then I added in my iOS project a pod with the library.
    pod install
    was also successful. When I’m trying to import library in the project I can do it (XCode sees the name of the library), however when I’m trying to build a project I’m getting an error
    No such module 'MobileLibrary'
    . What could be a problem?
    k
    Kris Wong
    3 replies
    Copy to Clipboard
  • m

    Marcin Bak

    1 year ago
    When I right click on kotlin source folder in commonMain there is no
    New
    ->
    Package
    action to create a package (which is there for jvmMain). Is there no packages concept in KMP or is it an issue with the IntelliJ?
    m
    s
    +1
    7 replies
    Copy to Clipboard
  • p

    Prateek Grover

    1 year ago
    anyone sharing model classes in KN between android and iOS? Specifically for iOS, if we do this, there is a huge limitation where even if the object is created in Swift (model class resides in KN), we cant use that object from multiple threads How are you guys working around it? Freezing?
    p
    s
    2 replies
    Copy to Clipboard
  • j

    janvladimirmostert

    1 year ago
    For Kotlin Multimodule Multiplatform projects, how does one configure the plugin block? Currently doing it per sub project
    plugins {
    	val kotlinVersion = "1.4.10"
    	kotlin("multiplatform") version kotlinVersion
    	kotlin("plugin.serialization") version kotlinVersion
    }
    but it no longer compiles complaining that i'm redefining the Kotlin plugin i guess this now needs to move to the
    allprojects {
    block in the root build.gradle.kts i'm trying
    allprojects {
      	plugins.apply(kotlin("multiplatform"))
    }
    but that's not compiling any ideas?
    j
    mbonnin
    15 replies
    Copy to Clipboard