• e

    edenman

    11 months ago
    anybody know if the KMM plugin is getting an update soon? Really frustrating to have it not working on latest AS
    e
    ankushg
    7 replies
    Copy to Clipboard
  • s

    Sylvain Patenaude

    11 months ago
    Hi folks, A client of our multiplatform libraries just told us they encountered a problem with our library for android, problem that apparently started with kotlin >= 1.4. (Stacktrace attached as a text file.) It looks like an issue with
    UByteArray
    where some generated method can't find a static method or something like that. Did something happen with unsigned types with kotlin >= 1.4? Thanks in advance, Sylvain
    s
    1 replies
    Copy to Clipboard
  • j

    jimmyt

    11 months ago
    I'm working on a KMM project with CocoaPods dependencies. For some reason unknown to me, the iOS Deployment Target for each Pod target on which my project depends is being set to 8.0 each time I try to sync the project, but the range of supported deployment target versions is 9.0 to 14.5.99, so each time I try to sync the project, it fails on the shared😛odBuild(PodName)Iphonesimulator task. I tried opening up the project in Xcode and changing the versions manually, but this does not work because the iOS Deployment Target is changed back to 8.0 each time I attempt to sync the project. What else can I do about this?
    j
    Matti MK
    7 replies
    Copy to Clipboard
  • xiaobailong24

    xiaobailong24

    11 months ago
    Hello, how to use
    annotationProcessor
    or
    kapt
    with jvm target but without android target?
    xiaobailong24
    itnoles
    2 replies
    Copy to Clipboard
  • Pavel Dektev

    Pavel Dektev

    11 months ago
    Hi everyone! I develop KMM app and I can’t run ios project from Android Studio. Maybe someone already had similar issue? From XCode I can build and launch app without any problem
    Pavel Dektev
    gildor
    +1
    11 replies
    Copy to Clipboard
  • coolcat

    coolcat

    11 months ago
    I am currently having difficulty building my KMM Android app from within Android Studio on my Mac. The iOS build works within Xcode, and the Android build also works OK on a non-Mac machine. The error is:
    Could not determine the dependencies of task ':shared:cinteropSharedIos'.
    > Could not resolve all dependencies for configuration ':shared:iosSharedCInterop'.
       > Authentication scheme 'all'(Authentication) is not supported by protocol 'file'
    Any help appreciated.
    coolcat
    Kirill Langer
    4 replies
    Copy to Clipboard
  • kenkyee

    kenkyee

    11 months ago
    For folks doing KMP w/ iOS and MVI, how do you handle iOS app state restoration (Android's savedstatehandle equivalent)? No luck searching this channel for "iOS app state restoration" which I thought was the right term for this...
    kenkyee
    m
    +5
    29 replies
    Copy to Clipboard
  • c

    cedric

    11 months ago
    Something I haven't seen in the various articles/presentations about Kotlin switching to a native WASM back end is: what was found insufficient in the existing LLVM back end? LLVM performs some really incredible optimizations in the assembly it generates, and it gets better every day, so I wonder if the Kotlin team can keep up with all the efforts going into LLVM, and whether it's time well spent...
    c
    russhwolf
    3 replies
    Copy to Clipboard
  • Kirill Langer

    Kirill Langer

    11 months ago
    Is there any way to use kotlin specific libraries for Kotlin Multiplatform Mobile common business logic? I have a dependency on Amplify that works fine for just android but doesn't support Kotlin Multiplatform Mobile. I am trying to use it for both ios and android GraphQL queries and subscriptions. I can't add this to common dependencies. Is this possible or do we need to switch to something like apollo for KMM for our GraphQL queries and subscriptions?
    Kirill Langer
    itnoles
    3 replies
    Copy to Clipboard
  • Vitaliy Zarubin

    Vitaliy Zarubin

    11 months ago
    For several evenings I have been unable to assemble the KMM default project on m1 in AppCode. Default project Android Studio crash after run application in simulator. Sadness. Yearning.
    Vitaliy Zarubin
    2 replies
    Copy to Clipboard