• j

    jimmyt

    10 months ago
    Hey, I'm trying to add a CocoaPod dependency to my KMM project and the build process keeps failing due to compiler errors during the cinterop task. But Gradle isn't telling me what the compiler error is, it is only telling me that a fatal error occurred. Even when I run with --info or --debug options, I don't get any more details about the compiler error. How can I get information from cinterop so that I can see what the problem is?
    j
    k
    7 replies
    Copy to Clipboard
  • k

    kavi

    10 months ago
    anybody come across any issues publishing to maven recently? we have a multi-module setup where our final Android lib – an SDK we’re building – has an implementation dependency on our KMM lib but have just run into this error whenever we try and build an android app that has a dependency on our SDK…
    Could not resolve all files for configuration ':samples:unflow-compose:debugRuntimeClasspath'.
    > Could not resolve com.unflow:unflow:1.0.1.
      Required by:
          project :samples:unflow-compose > com.unflow:unflow-ui:1.0.1
      > Could not determine whether value 7.2.0-alpha02 is compatible with value 7.1.0-beta02 using AgpVersionCompatibilityRule.
        > Using multiple versions of the Android Gradle plugin(7.2.0-alpha02, 7.1.0-beta02) in the same build is not allowed.
    k
    k
    3 replies
    Copy to Clipboard
  • Marcello Galhardo

    Marcello Galhardo

    10 months ago
    Does anyone have an example of KMM project (Android and iOS) designed as a Multi Module project? I want to avoid a monolithic "shared" module and I feel everything I find on the internet is very tiny examples... 🤔
    Marcello Galhardo
    Mustafa Ozhan
    2 replies
    Copy to Clipboard
  • xxfast

    xxfast

    10 months ago
    Hi, im trying to migrate from
    packForXCode
    to
    embedAndSignAppleFrameworkForXcode
    according to this. However, i dont see this task included by default. I’m on kotlin
    1.5.31
    . Am I missing something? It says
    new 
    embedAndSignAppleFrameworkForXcode
     in the generated project configuration.
    what if have an existing project that was generated before 1.5.20? 🤔 is there a way to bring this task to my existing project?
    xxfast
    1 replies
    Copy to Clipboard
  • j

    jimmyt

    10 months ago
    Has anybody discovered a reliable solution to the "module not found" error that sometimes appears when using CocoaPods with KMM? I've been encountering it seemingly at random for no reason, and I have yet to find a consistent way to fix it.
    j
    Martin Rajniak
    2 replies
    Copy to Clipboard
  • b

    Brian Donovan

    10 months ago
    Anyone has a sample project implementing login logic using KMM, Ktor with JWT? I’m super stuck on dependencies and every time I sync something crashes.
    b
    c
    3 replies
    Copy to Clipboard
  • Piotr Krzemiński

    Piotr Krzemiński

    10 months ago
    Is anyone interested in compiling Kotlin into Python? If so, please share your use case in this thread. Together with @SerVB we're working on compiling Kotlin to Python (#python). The more data about real use cases we have, the better we can do in terms of deciding on MVP's scope!
    Piotr Krzemiński
    hfhbd
    +1
    8 replies
    Copy to Clipboard
  • Mustafa Ozhan

    Mustafa Ozhan

    10 months ago
    Hello 👋 Maybe not related with Multiplatform but with the new android gradle plugin 
    7.2.0-alpha03
     I am unable to compiled my project, I have the scopemob(kmp library) project in the mentioned path and it works with 
    7.2.0-alpha02
     without problem
    Cannot find module with id: GradleProjectPath(buildRoot=/Users/mustafa.ozhan/Projects/Personal/CurrencyConverterCalculator/CCC, path=:scopemob, sourceSet=MAIN)
    Do you have any idea how to solve this ?
    Mustafa Ozhan
    louiscad
    5 replies
    Copy to Clipboard
  • TheOnlyTails

    TheOnlyTails

    10 months ago
    commenting out the
    complete-kotlin
    plugin fixes this.
    TheOnlyTails
    1 replies
    Copy to Clipboard
  • b

    Brian Donovan

    10 months ago
    I’m not sure why this is not importing
    b
    russhwolf
    7 replies
    Copy to Clipboard