• xiaobailong24

    xiaobailong24

    3 months ago
  • j

    Jonathan Ellis

    3 months ago
    it looks like kotlin stdlib does not have anything similar to java's SortedSet, am I missing anything?
    j
    e
    2 replies
    Copy to Clipboard
  • Marco Righini

    Marco Righini

    3 months ago
    Hello everyone, we are experiencing problems trying to debug multiplatform code from ios using https://github.com/touchlab/xcode-kotlin from touchlab. In particular in xcode we are trying to use step into for jumping from the swift code to the kotlin code. Is it a supported feature? Thanks!
    Marco Righini
    kpgalligan
    +1
    4 replies
    Copy to Clipboard
  • xiaobailong24

    xiaobailong24

    3 months ago
    Hello, how do you integrate kmm framework with Xcode project? Static or dynamic framework? What's the best way? I have used static umbrella framework in our production project. But the Xcode project compile-time is long enough when I update kmm static framework. So I want to know if dynamic framework is allowed and compile-time is shorter? Or is there any other problem with dynamic framework? Thanks.
    xiaobailong24
    1 replies
    Copy to Clipboard
  • Dimitri Giani

    Dimitri Giani

    3 months ago
    Hi, anyone has problem with KMM plugin and Android Studio that disable it?
    Dimitri Giani
    Konstantin Tskhovrebov
    4 replies
    Copy to Clipboard
  • Bruno Vaillant

    Bruno Vaillant

    3 months ago
    Hi, I have a problem creating a archive of my iOS projet with a KMM framework in it. The error message a receive is “Invalid Bundle. The bundle XXXXX.framework does not support the minimum OS Version specified in the Info.plist.” The MinimumOSVersion is 9.0 in the plist and my project support iOS14 and up. If i manually remove the MinimumOSVersion then I can archive it but if I change it to something else like 14.0 it’s still does not archive. Is there a way with embedAndSignAppleFrameworkForXcode to remove this MinimumOSVersion?
    Bruno Vaillant
    r
    +1
    6 replies
    Copy to Clipboard
  • Justin

    Justin

    3 months ago
    Has anyone made (or come across) any KMP iOS/Android libraries for dealing with the device camera (e.g. AVCaptureDevice on iOS, etc.)?
    Justin
    l
    +1
    6 replies
    Copy to Clipboard
  • j

    Jonathan Ellis

    3 months ago
    I have a project that I'm trying to update from jvm only to multiplatform (https://github.com/jbellis/delaunator). I took the basic multiplatform gradle build and added the maven-publish plugin. When I publish it locally, everything works. But when I try to consume it as a dependency from jitpack with a jvm-based client, I get an error that gradle couldn't find a jvm variant of the library (https://gist.github.com/jbellis/0d1cc53a64721f72b163a3b9152825e9). The jitpack pom is here https://jitpack.io/com/github/jbellis/delaunator/1.0.3.3/delaunator-1.0.3.3.pom and the build log is here https://jitpack.io/com/github/jbellis/delaunator/1.0.3.2/build.log. Nothing looks broken to me, but gradle is ignoring the -jvm artifact for some reason. Any ideas?
    j
    Big Chungus
    2 replies
    Copy to Clipboard
  • m

    miqbaldc

    3 months ago
    [SOLVED] Hi folks, recently we’re trying to integrate our codebase (Android & Kotlin module) to KMM But has problem when trying to sync it. We’re not sure if it the KMM side or the Android Plugin side, see error log in 🧵
    m
    2 replies
    Copy to Clipboard
  • Adam Brown

    Adam Brown

    3 months ago
    Anyone have a favorite KMP library for file Io?
    Adam Brown
    j
    +1
    6 replies
    Copy to Clipboard