jchildress
05/11/2017, 6:55 PMedvin
05/11/2017, 7:02 PMselect
statements instead. That would make sure that the actual value of the column is the name value instead of the fromBus value. I'll show you in a bit.jchildress
05/11/2017, 7:03 PMjchildress
05/11/2017, 7:06 PMedvin
05/11/2017, 7:13 PMcolumn<TheType, String>("Name", { SimpleStringProperty(it.value.fromBus.name) })
edvin
05/11/2017, 7:14 PMedvin
05/11/2017, 7:14 PMjchildress
05/11/2017, 7:15 PMron
05/11/2017, 7:16 PMnimakro
05/11/2017, 7:17 PMedvin
05/11/2017, 7:17 PMedvin
05/11/2017, 7:18 PMron
05/11/2017, 7:18 PMedvin
05/11/2017, 7:18 PMron
05/11/2017, 7:19 PMron
05/11/2017, 7:19 PMedvin
05/11/2017, 7:22 PMron
05/11/2017, 7:23 PMron
05/11/2017, 7:23 PMron
05/11/2017, 7:24 PMcarlw
05/11/2017, 7:27 PMron
05/11/2017, 7:28 PMron
05/11/2017, 7:28 PMcarlw
05/11/2017, 7:29 PMron
05/11/2017, 7:30 PMnimakro
05/11/2017, 7:38 PMedvin
05/11/2017, 7:48 PMcache
example above is that it needs a determinate key. cache(someKey) { returnSomeNode() }
would work. We would of course use a counter, but that's flimsy.edvin
05/11/2017, 7:49 PMcachedGraphic
property could be solved by using a static key, like a string with a value of`tornadofx.cachedGraphic`. For other use cases we need the key, or another approach. I can't think of anything off the top of my head.groostav
05/11/2017, 7:54 PMListCell
into its own named class, and pushed a bunch of business logic into it. The obvious win is that the previous class is now much smaller, but this new thing doesnt fit in MVC
nicely at all. How much would you push back on something like this? Would you push back at all?