Ruckus
03/26/2018, 3:43 PMchild
, contains
, next
, and sibling
). Not because they are better (in fact, I think I like the way you did it better; no reason to have multiple names for the same thing), but because those are the names for those functions we use elsewhere, and it should be consistent. Maybe we can look at renaming them when we do the whole CSS rewrite.Ruckus
03/26/2018, 3:48 PMthomasnield
03/27/2018, 3:34 AMedvin
03/27/2018, 6:47 AMedvin
03/27/2018, 6:49 AMURL("").readText()
, but if the resource is available on the classpath, you can do SVGIcon(resources.text("/path/to/iconm"))
mikehearn
03/27/2018, 9:53 AMmikehearn
03/27/2018, 9:53 AMmikehearn
03/27/2018, 9:53 AMmikehearn
03/27/2018, 9:54 AMkastork
03/27/2018, 2:54 PMmikehearn
03/27/2018, 3:03 PMmikehearn
03/27/2018, 3:03 PMmikehearn
03/27/2018, 3:04 PMmikehearn
03/27/2018, 3:04 PMmikehearn
03/27/2018, 3:04 PMmikehearn
03/27/2018, 3:05 PMmikehearn
03/27/2018, 3:06 PMmikehearn
03/27/2018, 3:07 PMmikehearn
03/27/2018, 3:07 PMcarlw
03/27/2018, 3:13 PMRuckus
03/27/2018, 4:20 PMs(a, b) {
and(c, d) {
child(e, f) {
next(g, h) {
sibling(i) {
fill = c("red")
}
}
}
}
}
becomes this monstrosity:
.a.c > .e + .g ~ .i, .a.c > .e + .h ~ .i, .a.c > .f + .g ~ .i, .a.c > .f + .h ~ .i, .a.d > .e + .g ~ .i, .a.d > .e + .h ~ .i, .a.d > .f + .g ~ .i, .a.d > .f + .h ~ .i, .b.c > .e + .g ~ .i, .b.c > .e + .h ~ .i, .b.c > .f + .g ~ .i, .b.c > .f + .h ~ .i, .b.d > .e + .g ~ .i, .b.d > .e + .h ~ .i, .b.d > .f + .g ~ .i, .b.d > .f + .h ~ .i {
-fx-fill: rgba(255, 0, 0, 1);
}
But it looks right...mikehearn
03/27/2018, 4:22 PMcarlw
03/27/2018, 4:53 PMkastork
03/27/2018, 11:19 PMnimakro
03/28/2018, 6:00 AMedvin
03/28/2018, 7:20 AMRuckus
03/28/2018, 7:56 AMRuckus
03/28/2018, 7:57 AMnekoinemo
03/28/2018, 8:57 AMmikehearn
03/28/2018, 10:40 AM