edvin
10/18/2016, 1:12 PMRuckus
10/18/2016, 2:12 PMadd(someClass)
and and(someClass)
will do an intersection, where as just someClass
will do nesting (so aClass { and(someClass) { ... } }
will be rendered as as .a-class.some-class { ... }
, while aClass { someClass { ... } }
will be rendered as .a-class .some-class { ... }
(notice the space)).user
10/18/2016, 2:15 PMs(listItem)
with just listItem
. It was a later change to increase readability.ron
10/18/2016, 2:16 PMselect
instead of s
(never understood the s
)Ruckus
10/18/2016, 2:19 PMs
alias for select
was just to be concise back when a wrapper function call was required (I got the idea from kotlinx CSS). It was a little annoying to see select(...)
all over the place and didn't really add clarity. Now that it only has to be used in limited circumstances, select
is definitely clearer.edvin
10/18/2016, 2:30 PMRuckus
10/18/2016, 2:36 PMand
, but by the time I realized my mistake, it was too late.Ruckus
10/18/2016, 2:37 PMadd
with a ReplaceWith("and(...)")
. Would that be cleaner?edvin
10/18/2016, 2:37 PMedvin
10/18/2016, 2:37 PMRuckus
10/18/2016, 2:37 PMedvin
10/18/2016, 2:37 PMRuckus
10/18/2016, 2:37 PMedvin
10/18/2016, 2:39 PMjchildress
10/18/2016, 2:39 PMs
, you are correct... much easier to read. thanksjchildress
10/18/2016, 2:39 PMadd
to and
Ruckus
10/18/2016, 2:40 PMron
10/18/2016, 2:45 PMjchildress
10/18/2016, 2:47 PMRuckus
10/18/2016, 2:58 PMedvin
10/18/2016, 3:53 PMRuckus
10/18/2016, 3:54 PMedvin
10/18/2016, 3:54 PMRuckus
10/18/2016, 3:54 PMedvin
10/18/2016, 3:54 PMedvin
10/18/2016, 3:54 PMedvin
10/18/2016, 3:59 PMedvin
10/18/2016, 4:00 PMRuntime.getRuntime().exec("powershell.exe Start-Process -FilePath java.exe -Argument '-jar runasadmin.jar' -verb RunAs");
ron
10/18/2016, 6:50 PMedvin
10/18/2016, 7:03 PM