https://kotlinlang.org logo
#ktlint
Title
# ktlint
p

Paul Dingemans

03/15/2023, 11:02 AM
You might want to try to change the order of the sections in your
.editorconfig
. The order is important when sections are not mutually exclusive afaik.
d

David Bilík

03/15/2023, 11:24 AM
unfortunately that did not help, still the same result
p

Paul Dingemans

03/15/2023, 3:55 PM
Another thing to try is to put another
.editorconfig
in directory
/build/generated/
or
/build
with content:
Copy code
# do not specify root = true

[*.{kt,kts}]
ktlint_standard_filename = disabled
d

David Bilík

03/15/2023, 3:59 PM
also did not help 😞
but tbh I’m not sure this
ktlint_standard_filename = disabled
directive works for me, if I have this editorconfig file
Copy code
root = true

[*.{kt,kts}]
ktlint_code_style = official
ktlint_standard_filename = disabled
I still have the error
p

Paul Dingemans

03/15/2023, 4:16 PM
You are using ktlint
0.48.x
or an older version?
When you run with
--log-level=debug
you get more information about what rules are run.
d

David Bilík

03/15/2023, 4:17 PM
I’ve updated kotlinter plugin to the newest version released yesterday and it started to work 😐 so maybe kotlinter had a dependency on an older version of ktlint
Apparently older version used 0.39.0 version of ktlint where these rules were not supported.
28 Views