I realized that collections do not have a shorthan...
# kotest
d
I realized that collections do not have a shorthand for
shouldBeNullOrEmpty()
, would it be useful to add this? It would just be a combination of
thing.shouldBeNull() || thing.shouldBeEmpty()
l
This one is a bit tough when negating it
ShouldNotBeNullNorEmpty?
ShouldNotBeNullOrShouldBeEmpty?
Removing that corner case, I don't see a reason why not
d
The inverse could just be shouldNotBeEmpty which includes a null check