Hi everybody! I just watched the super interesting talk by @simon.vergauwen and would like to bring something up regarding the Idiomatic API name consistency. It might've already been discussed and isn't actually that important but anyway here it is:
Some of the Either functions follow the right/left convention: Either.onRight(), Either.onLeft(). However, the counterpart to Either.leftOrNull is Either.getOrNull. In order to be consistent shouldn't it be named Either.rightOrNull? Or alternatively: Either.errorOrNull/Either.getOrNull. What do you think?