Travis Griggs

05/18/2023, 8:54 PM
(sorry for the crosspost, I got told the following did not belong in #getting-started, but not where to take the question, hopefully here?) IDE question. When I run my Compose app, Studio always jumps to the Run tab. But none of my println messages show up there. So I always have to flip over to Logcat, throw out the massive spewage that happens at startup, and then look for my statements. I tend to put recognizable emojis in my my output lines just so I can filter on those. I'd be happy with a solution for either: • Is there something simple I can do to get my println's to show up in the Run console? or • Is there a way to get the IDE to flip to the Logcat tab when starting, so I at least don't always have to renavigate back to it? Clear on start would be a bonus as well...

Chris Sinco [G]

05/18/2023, 9:44 PM
There’s a setting in the Run Configuration dialog to open up Logcat automatically
But I believe there is still an issue where the Run window shows up first, so be sure to uncheck
Activate tool window
option for the same run configuration

Travis Griggs

05/18/2023, 9:48 PM
Oh Thank YOU. I had searched in the main settings. Didn't think/realize to check in these settings.