I have these settings in my editorconfig and with ...
# ktlint
c
I have these settings in my editorconfig and with the latest ktlint version this combination no longer works:
Copy code
ktlint_standard_wrapping = disabled
ij_kotlin_allow_trailing_comma_on_call_site = false
ij_kotlin_allow_trailing_comma = false
it says
Copy code
- Rule with id 'RuleId(value=standard:trailing-comma-on-call-site)' requires rule with id 'RuleId(value=standard:wrapping)' to be loaded
is there any way to get this working again?
p
Try to disable the trailing comma rules. Those rules can only be used when also the wrapping rule is enabled. It is too complicated that each rule always can run without dependencies on other rules. More important question is why you want to disable the wrapping rule. A trick could be to set the max_line_length to an extreme high value and just enable the rule.
c
@Paul Dingemans ^ thats the reason why i disabled the wrapping rule
p
Ok tnx. To me this seems like a personal preference that ktlint is not able to cater for.
c
ok. I just want to avoid that a test description takes 4 lines when it does not fit into one line. but its also not a big deal
101 Views