Hi all. I'm following the <codeviewer example> to ...
# compose-desktop
Hi all. I'm following the codeviewer example to load fonts in my compose-multiplatform project. I've kept all the font assets in
directory and this is included in andorid sourcesets with
Copy code
android {
  sourceSets["main"].res.srcDirs("src/androidMain/res", "src/commonMain/resources")
However, now agp complaints with
Copy code
AGPBI: {"kind":"error","text":"The file name must end with .xml","sources":[{"file":"/Users/TFNX46/Developer/MULTIPLATFORM/NYTimesKMP/app/src/commonMain/resources/fonts/CheltenhamBold.ttf"}],"tool":"Resource and asset merger"}

Execution failed for task ':app:packageDebugResources'.
Am I missing a configuration? I'm using agp 8.0.1 with gradle 8.0
My guess is it expects the manifest.
Hmm.. cant see anything special on the manifests files
I remembered I had to add an empty manifest file, dunno why though, and not investigated further. You can check how I did it here . Though the resource are png files not font
I am facing the same issue, I have both manifests the same and build.gradle.kts resources management
1.5.0-beta02 & kotlin 1.9.0
in your PR, you have the fonts located in ‘fonts’. it should be under the folder ‘font’
👀 1
was running into the same error and that fixed it for me
I think it was fixed for me in prior versions