Does anyone have any idea why this error comes up?...
# multiplatform
d
Does anyone have any idea why this error comes up?
Copy code
:jsApp:commonTest: Could not find org.jetbrains.kotlin:kotlin-dom-api-compat:1.9.0-dev-6976.

Required by:
    project :jsApp > project :shared > org.jetbrains.kotlinx:kotlinx-coroutines-core:1.7.0-RC-wasm0 > org.jetbrains.kotlinx:kotlinx-coroutines-core-js:1.7.0-RC-wasm0
I am using: Kotlin
1.8.20
Compose
1.4.0-dev-wasm06
Coroutines
1.7.1
It's also very strange that it's required by "kotlinx-coroutines-core:1.7.0-RC-wasm0", when I am using 1.7.1 version instead. It's also referencing Kotlin 1.9.0-dev while I am using 1.8.20 instead. I paste the full error in the comment.
Copy code
:jsApp:commonTest: Could not find org.jetbrains.kotlin:kotlin-dom-api-compat:1.9.0-dev-6976.
Searched in the following locations:
  - <https://plugins.gradle.org/m2/org/jetbrains/kotlin/kotlin-dom-api-compat/1.9.0-dev-6976/kotlin-dom-api-compat-1.9.0-dev-6976.pom>
  - <https://dl.google.com/dl/android/maven2/org/jetbrains/kotlin/kotlin-dom-api-compat/1.9.0-dev-6976/kotlin-dom-api-compat-1.9.0-dev-6976.pom>
  - <https://repo.maven.apache.org/maven2/org/jetbrains/kotlin/kotlin-dom-api-compat/1.9.0-dev-6976/kotlin-dom-api-compat-1.9.0-dev-6976.pom>
  - <https://maven.pkg.jetbrains.space/public/p/compose/dev/org/jetbrains/kotlin/kotlin-dom-api-compat/1.9.0-dev-6976/kotlin-dom-api-compat-1.9.0-dev-6976.pom>
  - <https://maven.pkg.jetbrains.space/kotlin/p/wasm/experimental/org/jetbrains/kotlin/kotlin-dom-api-compat/1.9.0-dev-6976/kotlin-dom-api-compat-1.9.0-dev-6976.pom>
Required by:
    project :jsApp > project :shared > org.jetbrains.kotlinx:kotlinx-coroutines-core:1.7.0-RC-wasm0 > org.jetbrains.kotlinx:kotlinx-coroutines-core-js:1.7.0-RC-wasm0

Possible solution:
 - Declare repository providing the artifact, see the documentation at <https://docs.gradle.org/current/userguide/declaring_repositories.html>
j
Away from laptop but PeopleInSpace has wasm target now if you want to compare build setup
d
@John O'Reilly thanks!
The whole configuration is quite challenging at the moment. I hope with stable Kotlin 1.9, Wasm configuration will become easier
120 Views