Hello, using Kotlin `1.9.0-Beta` and set language ...
# k2-early-adopters
c
Hello, using Kotlin
1.9.0-Beta
and set language level to
2.0
to give K2 a try. Ran into some issues with my Kotlin Scripts not being picked up but used this flag
-Xuse-fir-lt=false
but now during compilation I get this (seemingly unrelated to kts)
Copy code
There are some plugins incompatible with language version 2.0:
  com.google.devtools.ksp.KotlinSymbolProcessingComponentRegistrar
Please use language version 1.9 or below
Is there no support 2.0 for KSP? I know things are bit iffy with that considering the nature of KSP/K2 but wondering if theres workaround
d
It's worth to ask about it in #ksp
a
You should specify what version of the ksp dependency you are using (
1.9.0-RC-1.0.11
is matching KSP version)