IMO `"11;33;44".split(";").let { Country(it[0], it...
# announcements
d
IMO
"11;33;44".split(";").let { Country(it[0], it[1], it[2]) }
is a bit uglier than a two liner
Copy code
val (id, code, name) = "11;33;44".split(";")
val country = Country(id, code, name)
it reads better. After using Kotlin a lot recently I feel like always trying to minimize number of lines sometimes impacts readability. At first you're so excited by this that you tend to overdo 🙂
👍 2