vgrechka
08/30/2016, 1:04 PMfun hoisting() {
doFirsThing()
thenSecond()
andSomethingMore()
fun doFirsThing() { /* Long function goes here */ }
fun thenSecond() { /* Long function goes here */ }
fun andSomethingMore() { /* Long function goes here */ }
}
Putting implementations of auxiliary functions after their usage is more readable to me than vice versa.