With kotlin synthetic binding it has removed the n...
# android
l
With kotlin synthetic binding it has removed the need to call
findViewById()
so now you can directly access the resource id and use that to set properties on a View. In this case what is a good naming convention for resource ids of views and view groups? Should the resource id be snake_case , camelCase or something else? Also, should the resource id exclude the name is the view or view group from the name? For example, not something like titleTextView, since Android Studio will show you what the type of a variable is in a grey hint next to the variable name. What about other resource ids like strings, drawables, dimensions ... Do those stay snake_case or have they all gone camelCase?