thanksforallthefish
12/18/2018, 4:09 PMfileRetriever.retrieveFileInformation(representation.file.fileUid).let {
Masterplan(
representation.description,
it,
projectUid
)
}.let {
masterplanRepository.save(it)
}
and IDEA complains about the first let
being redundant. it suggests
Masterplan(
representation.description,
fileRetriever.retrieveFileInformation(representation.file.fileUid),
projectUid
).let {
masterplanRepository.save(it)
}
I personally like the first version more because it shows better what the flow is (translate into read left to right, top to bottom). thoughts?