It's me again with compose wasm. I can now run th...
# compose-web
It's me again with compose wasm. I can now run the app locally, but when I try to distribute it using
I get :
Copy code
FAILURE: Build failed with an exception.

* What went wrong:
Execution failed for task ':webApp:compileKotlinJs'.
> A failure occurred while executing org.jetbrains.kotlin.compilerRunner.GradleCompilerRunnerWithWorkers$GradleKotlinCompilerWorkAction
   > Compilation error. See log for more details
which is weird because I can run the app without a problem. The IDE (only in the WASM target) cannot figure out the dependencies. Anyone tackled this or might have any pointers?
👀 1
tldr: something is up with the default wasm sample project, which i didnt bother figuring out. I ended up using People In Space as a starter instead.
was your intention to build a js distribution? running a js app doesn't work either (js source set is indeed broken). Perhaps, you've tried to run wasm app? and you wanted to build a wasm distribution?
fixed ths js compilation and distribution in the main branch
i wanted to build a wasm app indeed. here is everything i tried out and what I ended up doing. I was able to deploy it at
🎉 1