https://kotlinlang.org logo
#gradle
Title
# gradle
m

Marc Knaup

02/28/2017, 7:26 PM
Hey guys, are the latest Gradle snapshots broken? I can’t build my Kotlin project with anything newer than
gradle-script-kotlin-3.5-20170222192057+0000
.
Copy code
Generating JAR file 'gradle-api-3.5-20170228135430+0000.jar'
Generating JAR file 'gradle-script-kotlin-extensions-0.8.0-SNAPSHOT-3.5-20170228135430+0000.jar'
Error: Unresolved reference: jetbrains (<snip>/_Project_accessors.kt (31:37))
Error: Unresolved reference: jetbrains (<snip>/_Project_accessors.kt (32:30))
Error: No value passed for parameter p1 (<snip>/_Project_accessors.kt (32:110))
Error: Unresolved reference: jetbrains (<snip>/_Project_accessors.kt (37:35))
Error: Unresolved reference: jetbrains (<snip>/_Project_accessors.kt (38:30))
Error: No value passed for parameter p1 (<snip>/_Project_accessors.kt (38:102))
Error: org.jetbrains.kotlin.codegen.CompilationException: Back-end (JVM) Internal error: Failed to generate function kotlin
Cause: Error type encountered: [ERROR : org.jetbrains.kotlin.gradle.dsl.KotlinProjectExtension] (ErrorTypeImpl).
File being compiled and position: (28,1) in <snip>/_Project_accessors.kt
PsiElement: /**
 * Retrieves or configures the [kotlin][org.jetbrains.kotlin.gradle.dsl.KotlinProjectExtension] project extension.
 */
fun Project.`kotlin`(configure: org.jetbrains.kotlin.gradle.dsl.KotlinProjectExtension.() -> Unit = {}) =
    extensions.getByName<org.jetbrains.kotlin.gradle.dsl.KotlinProjectExtension>("kotlin").apply { configure() }
The root cause was thrown at: KotlinTypeMapper.java:147