Nevertheless, I have plans to change it, because I...
# opensource
v
Nevertheless, I have plans to change it, because I think it more convenient to have all query methods with the same prefix. In fact, there is already a method quite similar to the firstItem calculated property, which is the queryFirst(query: (RealmQuery<T>) -> Unit) method. So in the next release, I will provide a similar method without the condition argument, something like queryFirst(), to use instead of the firstItem property. I'm going to replace the lastItem and allItems properties with queryLast() and queryAll() too.