I think we could rename all those data types for e...
# arrow-contributors
r
I think we could rename all those data types for example from:
ListKW
->
ListK
IMO this would be a better name because: 1.
ListK
is the kinded capable version of
List
2.
listOf(1, 2, 3).k()
is already the extension used to bring a regular std lib
List
into it's kinded capable type
class ListK<A>(list: List<A>) : List<A> by list, ListKKinded<A>
. 3. The
K
postfix termination is already in use in Arrow in type class that operate over the the structure of the type constructor and not it's contents. Examples of these are
SemigroupK
,
MonoidK
,
FunctionK
etc. Thoughts?