Hi all, I want to publish my kmm library and I am ...
# multiplatform
Hi all, I want to publish my kmm library and I am following this articles. The issue is running
clean was giving the error
Copy code
xecution failed for task ':convention-plugins:compileKotlin'.
> Error while evaluating property 'compilerOptions.jvmTarget' of task ':convention-plugins:compileKotlin'.
   > Failed to calculate the value of property 'jvmTarget'.
      > Unknown Kotlin JVM target: 20
So I added
Copy code
kotlin {
the project build successfully after that, but I can’t see any publish related task. Can anyone please point me to the right direction
./gradlew publishAllPublicationsToSonatypeRepository
show build successful but I can’t see anything in my dashboard staging repository
Try clicking “refresh” and wait a minute
have tried but still not able to see anything also i can successfully execute
./gradlew publishAllPublicationsToSonatypeRepository,
but there is nothing in my repository
Screenshot 2023-09-11 at 5.20.53 PM.png
it seems like a android studio issue, I can see all the gradle task in my terminal. But the issue is after running the command .
/gradlew publishAllPublicationsToSonatypeRepository,
why it’s still not creating the staging repository in sonatype. Is there anything that I am doing wrong here This is my local.properties
Copy code
signing.keyId=last 8 digit of my id 
signing.password=passphrase used 
ossrhUsername=my userName
Anyone can please help me here
Please uncheck the “also send to the channel” checkbox when replying in the thread. It will post your answer to the channel.
That said, how did you configure the sonatype repository?
I have followed this article, the only difference is that for domain I have used
. Also, in my sonatype dashboard I can see staging profile