# ios


09/28/2023, 9:14 AM
I have a similar issue to Kevin yesterday and exactly the same as someone in the multiplatform channel a while ago. Unfortunately there were no solutions posted, and I cannot find a solution either. I can build my android and ios app fine, but I get this message for the Previews:
Execution failed for task 'sharedembedAndSignAppleFrameworkForXcode'.
Failed to create directory '~/Library/Developer/Xcode/DerivedData/CompanyInfoUk-fwwlyhkcdbhqjlcdfhgcjsnfrwcg/Build/Intermediates.noindex/Previews/CompanyInfoUk/Products/Debug-iphonesimulator/'
I updated Xcode to 15.0 a while ago, but I haven't used it since, I think. Some settings might be the culprit, because there was another issue, that I solved by turning off 'User Script Sandboxing'. However I cannot solve this one. Maybe solving the other problem caused this one, meaning I need script sandboxing?


10/05/2023, 2:08 PM
@BaBeStudios has you managed to solve the issue? I’ve tried testing similar scenarios and haven’t found any problems. If you could share the project or another reproducer that would be great. Btw which error have you fixed by disabling
User Script Sandboxing
? My tests also shows that everything works with it enabled


10/05/2023, 2:16 PM
Yes, sorry, I posted it in Multiplatform, and only posted the solution there. Which was: I did not realise, that performing 'Clean Build Folder..' won't clean the DerivedData folder above, which is obviously different. It was corrupted somehow, so deleting it solved the issue. I cannot reproduce it, it was borked by some action, maybe in Android Studio. Sorry, but I don't remember the other issue exactly, I'm new to xcode, so I had a lot.
thank you color 1