# multiplatform


09/29/2023, 7:43 AM
Cross posting from ios channel in the hope that more people read it here. My android and ios apps build fine, but I have the following error message for Xcode Previews:
Execution failed for task 'sharedembedAndSignAppleFrameworkForXcode'.
Failed to create directory '~/Library/Developer/Xcode/DerivedData/CompanyInfoUk-fwwlyhkcdbhqjlcdfhgcjsnfrwcg/Build/Intermediates.noindex/Previews/CompanyInfoUk/Products/Debug-iphonesimulator/'
It could be some SwiftUI code files I added recently, but removing them did not help. I updated Xcode to 15.0 a while ago, but I haven't used it since, I think. Not sure. Some settings in the new version might be the culprit, because there was another issue, that I solved by turning off 'User Script Sandboxing'. However I cannot solve this one. Maybe solving the other problem caused this one, meaning I need script sandboxing?
This is resolved. I did not realise, that performing 'Clean Build Folder..' won't clean the DerivedData folder above, which is obviously different. It was corrupted somehow, so deleting it solved the issue.