# getting-started

Stephan Schröder

10/12/2023, 2:58 PM
so I have my little demo project with a minimal Spring Boot Application with Maven and Kotlin and it works, but there are two open questions: • adding
to the properties section of the main pom-file should switch the bytecode version, produced, but doesn't (i also tried
because that's how the documentation shows it, but I've see a bug ticket where an Int was used and nobody complained about it) but the Bytecode version is still JDK17 which is the JDK at JAVA_HOME:
Copy code
$ file ./application/target/classes/com/example/multimodule/application/MyController.class 
./application/target/classes/com/example/multimodule/application/MyController.class: compiled Java class data, version 61.0
• the documentation tells me to create a
file with
Copy code
in it in order to use JDK 17, but it didn't and everything still worked und I do use a JDK 17 🤷‍♂️ I later added it and nothing changed. So what is this supposed to be for?


10/12/2023, 3:35 PM
the spring boot parent manages the target based on the
👍 1