# intellij


10/28/2023, 1:50 AM
I’m trying to do some debugging in IntellJ 2023.2.4 (MacOS 13.2.1) and for some reason my breakpoints aren’t activating for some reason. This is not a problem I’ve had in prior versions of IntelliJ, but I can’t find any guidance on what I might be missing configuration/setup wise. I’ve created two versions of a simple program: one with
loop and console input and one without. You can see from the screenshots that: 1. The program without the console input activated the debugger, ran the program, then immediately exited. The breakpoints seem to be active as normal. 2. The program with the input loop activates the debugger, and runs the loop, and the program runs as expected, but the breakpoints are deactivated and tooltip states “Breakpoint does not belong to any class”. I’ve invalidated caches and restarted and rebuilt but get the same result. There must be some configuration step I’m missing - but I can’t see what it could be. Any help much appreciated!
For anyone interested: I ran the same project in IntelliJ IDEA Ultimate and it worked fine. So I did a reinstall of CE and everything now works fine. Not sure what the root cause was…

Edoardo Luppi

11/01/2023, 1:13 PM
@Ashley it's random BTW. Happens in Ultimate too. The debugging experience is yet not the best.