# touchlab-tools


10/31/2023, 9:24 AM
Hi guys, we are trying to add kotlin-xcode plugins step by step following the instructions on github readme, but looks like it doesn’t work as expected, I wonder if the plugin enabled correctly, and when I run my app in xcode, I cannot set breakpoint in kotlin code, and I run xcode-kotlin in terminal everything seems all right and compatible. any ideas which parts I was doing wrong?🥲 thanks (I tried on xcode15.0.1 and xcode 15.1 beta, xcode-kotlin 1.3.0. both the same situation)


10/31/2023, 1:29 PM
It looks like it's color the source, so it loads to some dergee at least. Do you have maybe a video of trying to set the breakpoint?


11/01/2023, 2:04 AM
here we have a video, seems to breakpoint not able to enter, it keeps become invalid, and I am pretty sure app will run this code
still fighting for this 😵‍💫, I am wondering if this require KMMBridge? because I can place a breakpoint, but when I run code it shows a hollow array like this , so I am guessing if the lib can’t be found in runtime. (we are using cocoapod plugin in kmp project and install from local
solved. that is because I put the pod in our private git repo, if I changed to local, it works