https://kotlinlang.org logo
#javascript
Title
# javascript
g

georgi

11/26/2023, 5:04 PM
👋 Heya! Weird issue - I seem to have stopped seeing the option to "Run" tests from IntelliJ directly. When I run via
./gradlew jsNodeTest
on the command line they are all executed as expected. I also don't seem to have the little arrows next to the test class name or methods. Screenshot in 🧵 Has this happened to anyone else? I'm on • IntelliJ 2023.2.5 • Gradle 8.4 • Kotlin 1.9.21
1
Here's what I'm seeing. The test sources all seem okay and the same happens on
commonTest
folders.
My gradle setup is something like
Copy code
js(IR) {
    binaries.library()
    nodejs()
}
I also tried something like
Copy code
js(IR) {
    binaries.library()
    nodejs {
        testTask {
            useMocha()
        }
    }
}
with no difference
Also tried invalidating cashes and restarting and still the same
t

turansky

11/26/2023, 9:28 PM
I have similar issue
Even with
browser
target
Could you please report it on YouTrack?
e

Edoardo Luppi

11/26/2023, 10:34 PM
Are you targeting JS only or also other platforms?
The JS test runner has been hidden under the Experimental features flag. Be sure to have it checked.
👍 1
This goes back to September, so it's strange you haven't noticed before. Maybe you never had a single target only? https://youtrack.jetbrains.com/issue/KTIJ-27172
g

georgi

11/26/2023, 10:50 PM
The JS test runner has been hidden under the Experimental features flag.
Ah that solved it, amazing!
so it's strange you haven't noticed before
I do have only a
js
target and my CI is mostly running the tests so I didn't notice until I had to add a few new tests 😅 Thanks for pointing this out 🙌
✔️ 2
2 Views