https://kotlinlang.org logo
#ktor
Title
# ktor
t

tylerwilson

11/27/2023, 4:56 PM
Tried updating to the 3.0.0-beta-1 release in my KMP module. Android works fine, but when trying to build the XCFramework,. I get this error:
Copy code
Could not find "io.ktor:ktor-utils-cinterop-threadUtils" in [/Users/tylerwilson/Projects/SalonBiz/salonbiz-stylist-android, /Users/tylerwilson/.konan/klib, /Users/tylerwilson/.konan/kotlin-native-prebuilt-macos-aarch64-1.9.21/klib/common, /Users/tylerwilson/.konan/kotlin-native-prebuilt-macos-aarch64-1.9.21/klib/platform/ios_arm64]
Anybody else see this?
a

Aleksei Tirman [JB]

11/28/2023, 9:12 AM
This must be the problem, which is fixed in Kotlin 1.9.21. Here, you can find a workaround. A new upcoming beta version will contain the fix.
t

tylerwilson

11/28/2023, 5:19 PM
Thank you. I am using 1.9.21. When you say upcoming beta version I am hoping you are referring to Ktor, not Kotlin...
a

Aleksei Tirman [JB]

11/28/2023, 6:00 PM
Yes, the Ktor's beta.
👍 1
3 Views