https://kotlinlang.org logo
#compose-ios
Title
# compose-ios
j

Joel Denke

02/26/2024, 7:03 AM
I tried to find out what this means but couldnt find anything, so I ask here:
Copy code
Cannot infer a bundle ID from packages of source files and exported dependencies, use the bundle name instead: ComposeApp. Please specify the bundle ID explicitly using the -Xbinary=bundleId=<id> compiler flag.
I get this from task
> Task :composeApp:linkReleaseFrameworkIosArm64 FAILED
in any sample project from kmp.jetbrains.com What bundle id should be inserted where? In general I am very very confused by iOS compile errors, almost zero information everytime something fails. Maybe there is some debug flags I can add?
c

curioustechizen

02/26/2024, 7:05 AM
I see this as well but it doesn't stop my build. I mean my build continues and I can install and run the app just fine.
j

Joel Denke

02/26/2024, 7:06 AM
Yeah this is me trying hunt down every single warning I get (Going to treat all warnings as errors in gradle if I can soon) 🙂 It can compile as well, but differ between release vs debug builds, where I think some things will brick. When I do clean rebuild I get errors and warnings, but it still says successful ... And next time doing incremental build it works. Very confusing :S Tried follow https://youtrack.jetbrains.com/issue/KT-56152 but without luck.
d

Dima Avdeev

02/26/2024, 9:15 AM
j

Joel Denke

02/26/2024, 9:18 AM
Thanks, I have the bundleId in my
iosApp/Configuration/Config.xcconfig
file but doesnt look like CMP respect it in newer 1.6.0-rc01+ versions, or fails parsing it, not sure.
11 Views