https://kotlinlang.org logo
#compose-ios
Title
# compose-ios
j

Joel Denke

02/28/2024, 8:48 AM
0x13b027060 - ProcessAssertion::acquireSync Failed to acquire RBS assertion 'WebProcess NearSuspended Assertion' for process with PID=96000, error: Error Domain=RBSServiceErrorDomain Code=1 "target is not running or doesn't have entitlement com.apple.runningboard.assertions.webkit" UserInfo={NSLocalizedFailureReason=target is not running or doesn't have entitlement com.apple.runningboard.assertions.webkit}
Failed to open URL <com.myapp.test://google/link/?request_ip_version=IP%5FV4&match_message=No%20pre%2Dinstall%20link%20matched%20for%20this%20device%2E>: Error Domain=NSOSStatusErrorDomain Code=-10814 "(null)" UserInfo={_LSLine=277, _LSFunction=-[_LSDOpenClient openURL:fileHandle:options:completionHandler:]}
When I run my IOS app in CMP in XCode with run on my Mac (as Ipad) I get above crash immeditatly. Anyone else tried this or recognize the error? Note: I do not use any webviews or such, at least nothing myself. Maybe from GoogleSignIn or such, not sure.
d

Dima Avdeev

02/28/2024, 3:17 PM
Can you please create a minimal reproducible sample of this project?
And create an Issue with attached link to project https://github.com/JetBrains/compose-multiplatform/issues/new/choose
j

Joel Denke

02/28/2024, 3:24 PM
Not sure I can, as need provisioning profile signed as well as probably same setup as I have in my app, which I am not able to completely share I think. To me feels like something else, as this error looks like solveable if you are the one creating the webview. But I dont undersand whats using WebView/WebKit at all, if its CMP level or where its at. From what I understand need
Copy code
webView.allowsLinkPreview = true
but also correct BackGround Modes enabled. The latter I did do, but didnt help. I start wondering if its something with my AVPlayer solution, where I in the beginning of the app having video rendering. Will try disable it and see if thats the root cause.
6 Views