https://kotlinlang.org logo
#k2-early-adopters
Title
# k2-early-adopters
r

Robert Jaros

03/05/2024, 6:56 PM
When working with Kotlin 2.0.0-Beta4 in the latest InteliJ IDEA I've got a lot of errors, which are not really there (gradle build works fine). I assume the IDE compiles my code with Kotlin 1.9. Can I somehow make it use Kotlin 2?
j

Javier

03/05/2024, 7:53 PM
have you enabled k2 setting in the IDE?
r

Robert Jaros

03/05/2024, 8:03 PM
How can I do this? I don't see any options.
r

Robert Jaros

03/05/2024, 8:06 PM
So I need a separate, dedicated EAP IDE?
j

Javier

03/05/2024, 8:06 PM
only 2024 versions has k2
r

Robert Jaros

03/05/2024, 8:10 PM
Thanks
2 Views