https://kotlinlang.org logo
#compose-ios
Title
# compose-ios
u

uli

03/06/2024, 10:36 AM
Maybe a stupid question, but where exactly do I have to set the
compose { kotlinCompilerPlugin }
? I have set the compiler plugin in first thing, top level in every module and still get this error in the
compileDebugKotlinAndroid
target.
Copy code
e: This version (1.3.2) of the Compose Compiler requires Kotlin version 1.7.20 but you appear to be using Kotlin version 2.0.0-Beta4 which is not known to be compatible.  Please fix your configuration (or `suppressKotlinVersionCompatibilityCheck` but don't say I didn't warn you!).
What did I miss?
a

Albert Chang

03/06/2024, 10:49 AM
Check if you are specifying
Copy code
android {
    buildFeatures {
        compose = true
    }
}
This should be removed.
u

uli

03/06/2024, 10:49 AM
oh, interesting. thanks
That worked. And knowing it, it even makes sense 🙂
5 Views