https://kotlinlang.org logo
#multiplatform
Title
# multiplatform
a

Angga Ardinata

03/08/2024, 8:23 AM
Hey every one .. i have issues after compiling the iOS source the build says in success and will run the app .. however the app not open or installed on simulator .. if there is no simulator open .. kmm will not open/launch the simulator too .. im running hackintosh with amd .. the simulator is launched on ventura and now im downgrading to monterey .. i tried to compiled the project from compose multiplatform wizard and still no simulator launch ..
Copy code
Environment diagnose:
[✓] Operation System
  ➤ Version OS: macOS 12.7.3
    CPU: AMD Ryzen 5 5600G with Radeon Graphics

[✓] Java
  ➤ Java (java version "17.0.10" 2024-01-16 LTS)
    Location: /Library/Java/JavaVirtualMachines/jdk-17.jdk/Contents/Home/bin/java
  ➤ JAVA_HOME: /Library/Java/JavaVirtualMachines/jdk-17.jdk/Contents/Home

[✓] Android Studio
  ➤ Android Studio (AI-232.10227.8.2321.11479570)
    Location: /Applications/Android <http://Studio.app|Studio.app>
    Bundled Java: openjdk 17.0.9 2023-10-17
    Kotlin Plugin: 232-1.9.0-release-358-AS10227.8.2321.11479570
    Kotlin Multiplatform Mobile Plugin: 0.8.2(232)-20
  i Note that, by default, Android Studio uses bundled JDK for Gradle tasks execution.
    Gradle JDK can be configured in Android Studio Preferences under Build, Execution, Deployment -> Build Tools -> Gradle section

[✓] Xcode
  ➤ Xcode (14.2)
    Location: /Applications/Xcode.app
  i Xcode JAVA_HOME: /Library/Java/JavaVirtualMachines/jdk-17.jdk/Contents/Home
    Xcode JAVA_HOME can be configured in Xcode -> Settings -> Locations -> Custom Paths

[!] CocoaPods
  ! CocoaPods configuration is not required, but highly recommended for full-fledged development
  ➤ ruby (ruby 2.6.10p210 (2022-04-12 revision 67958) [universal.x86_64-darwin21])
  i System ruby is currently used
    Consider installing ruby via Homebrew, rvm or other package manager in case of issues with CocoaPods installation
  ➤ ruby gems (3.0.3.1)
  ✖ cocoapods not found
    Get cocoapods from <https://guides.cocoapods.org/using/getting-started.html#installation>

Recommendations:
  ➤ IDE doesn't suggest running all tests in file if it contains more than one class
    More details: <https://youtrack.jetbrains.com/issue/KTIJ-22078>
Conclusion:
  ✓ Your operation system is ready for Kotlin Multiplatform Mobile Development!
a

Andrei Salavei

03/08/2024, 9:08 AM
Hey! XCode 14.2 is too old. So as a guess: Install new XCode (15.2), create standard iOS project using XCode and try to run it. If it goes successfully, then get back to your project.
a

Angga Ardinata

03/08/2024, 9:14 AM
can i installed it in monterey ?
icannot go up after monterey due to vbox 6.1 is the latest supported for monterey
is the KMP Plugins really dont support older macOS version ? @Andrei Salavei
a

Andrei Salavei

03/08/2024, 9:41 AM
Not sure about the support. You can file a ticket in our YouTrack about it. Apple recommends using the latest XCode, and it will be strict requirement if you want to upload your app to AppStore. Couple of things I can suggest: • Try to build & run the project from XCode. Lots of our templates has this ability. • Find the place where your application is located. Be sure it was built for simulator. Then open iOS Simulator app, and drag-drop your application into simulator window. Then you will be able at least to run it.
9 Views