https://kotlinlang.org logo
#multiplatform
Title
# multiplatform
m

Michal Havryluk

03/14/2024, 4:53 PM
I have little problem with Android Studio and KMM plugin. The "debug" icon is disabled and I would swear that it was working in the past (Hedgehog?). So I'm not unable to debug / attach debugger / set breakpoints to shared code when running iOS app. I'm using Android Studio Iguana (tried also Jellyfish), KMM plugin (0.8.2), Kotlin 1.9.21, Gradle 8.2.2. I hope that I'm just missing some little detail somewhere. Thanks for any hint what to check.
🔍 1
g

Gleb

03/15/2024, 9:13 AM
I don’t exactly remember how I solved, but I was able to google the answer. Now that I tried again, I was not. Try doing this settings -> advanced -> search “kotlin” -> enable experimental features support That’s one of the many things I had to do to make my kmp development experience smoother. Perhaps this one was related to debug actually. Also, note that native debug work differently compared to jvm debug, you’ll find out when you have it solved
m

Michal Havryluk

03/15/2024, 12:42 PM
Yes, thank you. It's working now and debug icon is enabled.
👍 1
3 Views