https://kotlinlang.org logo
#naming
Title
# naming
k

Kev

03/15/2024, 9:59 AM
What would you call a feature that blocks access to URL’s until a person has gone through an OTP authorization process?
o

Oliver.O

03/15/2024, 10:01 AM
AuthorizationGate?
b

bod

03/15/2024, 10:01 AM
AuthorizationInterceptor
s

Sam

03/15/2024, 10:01 AM
plus1 for gate, or also barrier
2
Interceptor tends to refer to a specific design pattern, so it might or might not be appropriate, depending on the actual code
k

Kev

03/15/2024, 10:03 AM
AuthorizationGate has a nice ring to it
I agree, interceptor is misleading
o

Oliver.O

03/15/2024, 10:04 AM
Yep, "interceptor" is pretty generic and does not communicate what is actually done when intercepting.
y

Youssef Shoaib [MOD]

03/15/2024, 10:54 AM
The "GirlBoss" because it gatekeeps the URLs :D More seriously, something with gatekeeper or guard could sound quite cool
💂🏾 1
☠️ 2
💂 1
s

Sam

03/15/2024, 10:58 AM
I once worked on a system where the auth component was named Heimdall. (Not my idea.) It was cool and all, but it did mean stopping to explain it to every new engineer who came onto the project.
o

Oliver.O

03/15/2024, 12:31 PM
Can relate. For stuff that we deal with on a daily basis, naming almost doesn't matter and we could choose "Red", "Green", ... for whatever it really is. Onboarding is a thing (which may include you having to onboard again on stuff your former self wrote, after it has just been working quietly for a couple of years). So precise naming generally does make a difference. I always advocate avoiding anything "...er"-like as these function/role classes are blurry and tend to accumulate unrelated tasks over time.