https://kotlinlang.org logo
#intellij
Title
# intellij
h

hfhbd

03/20/2024, 8:45 AM
First time I saw this feature:
Enable sync with future AGP version
finally 🚀
🚀 1
h

hfhbd

03/20/2024, 8:52 AM
Yes, because 2023.3 uses the back ported android plugin 14808.21 but beta uses an older version 13688.18
w

wasyl

04/04/2024, 4:29 PM
well 2024.1 stable is out and the option is still missing kodee sad Looking at https://plugins.jetbrains.com/plugin/22989-android/versions it looks like 2024.1 is not using some old version, unless this plugin's versioning doesn't relate to actual Android plugin functionality?
h

hfhbd

04/04/2024, 5:00 PM
The version 14494 used by 2024.1 still older than the version 14808 used by 2023.3 😐
w

wasyl

04/04/2024, 5:03 PM
Ah so in the plugin version, the first part is IJ version/compatibility, second is actual Android plugin, third is ~whatever? So the most recent 2023.* version is actually 233.15026.9 which is Android plugin 15026. So I need to wait for 241.148* or 241.150* version, got it 👍 A bit confusing, and disappointing that it takes so long to update, but oh well 🤷
h

hfhbd

04/04/2024, 5:08 PM
Yes, first one is IntelliJ version. The last one is some bug fix number I guess.
Google should provide the plugin directly, currently JetBrains waits for a new release and „backports“ the plugin to a newer IntelliJ version.
w

wasyl

04/04/2024, 5:56 PM
So is the Android plugin not yet published, not yet picked up by JB or it's just non-trivial effort to backport?
w

wasyl

04/08/2024, 6:50 AM
Well that's disappointing, given that the toggle did exactly what it advertised and allowed me to work with new AGP in IJ 23.* 😢 Thanks for linking the issue!
4 Views