Hello folks, how are you doing today? I'm having ...
# kotest
c
Hello folks, how are you doing today? I'm having the same problem described in this post: https://slack-chats.kotlinlang.org/t/517348/i-m-getting-engine-exception-when-trying-to-run-kotest-tests Every time I try to run one test individually, it fails with the following message:
Copy code
system/path/ValueCastingTest has been compiled by a more recent version of the Java Runtime (class file version 64.0), this version of the Java Runtime only recognizes class file versions up to 61.0
When I run them all at once though, they pass. I noticed that when they run individually, the jbr/bin/java runner is picked by default. Is there a way to tell Kotest to always choose the JDK_HOME environment variable? My JDK Home points to JDK 20, so does my Gradle settings I got the plugin installed and all dependencies up-to-date (5.8.1) This is my test class:
Copy code
internal class ValueCastingTest : FunSpec({
    test("castTo should return a valid value") {
        ValueCasting.castTo<List<Int>>(arrayListOf(defaultInteger()))
            ?.first()
            .shouldBe(defaultInteger())
    }

    test("castToNonNullable should return a valid value") {
        ValueCasting.castToNonNullable<List<Int>>(arrayListOf(defaultInteger()))
            .first()
            .shouldBe(defaultInteger())
    }
})
Thank you so much ­čĹŹ