Thread
#multiplatform
    v

    Venkataramanan Parameswaran

    1 month ago
    hi i created a KMM library in my existing kotlin project. and when i use it without adding any other dependency in my xcode project it builds fine... but if i add coroutines or any other library (tested with ktor and kotlinx-serialization) my xcode project build fails.. but android works fine... ios build failed with the error stating that the particular dependency not found... can anyone please help me on this issue
    Landry Norris

    Landry Norris

    1 month ago
    Try removing the iosSimulatorArm64 target.
    You should be able to set XCode to run the simulator as x86_64.
    v

    Venkataramanan Parameswaran

    1 month ago
    I removed them from build.gradle's sourcesets but still facing the same error... ?
    is removing the sourceset's from build.gradle file is enough?
    Actually i have another kmm project also... in that everything works fine... but this project was already a kotlin project ... i just created a kmm library.. do i need to configure anything in the project level when creatiing a kmm library in a existing project?
    Solved the problem by updating my dependencies to latest version.