I wonder, how come AS Electric Eel Canary 10 came ...
# android-studio
I wonder, how come AS Electric Eel Canary 10 came out, which needs android gradle plugin
, however the
dependency here doesn’t have that version? Is this something that happens often? I add an
dependency on this in some of my convention plugins and it is not resolving since it doesn’t exist. Downgrading to Canary 09 works all fine again 🤔 I must be missing some piece of the puzzle I believe.
Does it need that gradle plugin version though? I run the canary 10 with gradle plugin 7.2.0 without problems so that other team members are not forced to run canary 🙂
Aha 🤔 When I updated and opened the project which was in
at that point it as telling me it needed to go to 10. Maybe it’s more about the alphas specifically, but one can still use the stable channel. Haven’t tried going with the canary on a stable agp version actually, that is true.
i typically stay on canaries the entire time. from a convo i had with Xav in issue tracker, you should be able to use stable agp in AS canaries now. but in canaries if agp is alpha, you will need to use the alpha that matches up to AS canary.
Yeap that does make sense. I hadn't thought that it'd work like that, that an older version works, a newer too, but not the in-between one. Thanks for confirming this for me 👌