Thread
#multiplatform
    b

    Bohdan

    3 weeks ago
    Hi, I have an issue with pod on ios. I am using some analysis in shared code - and it works fine in code(I am able to use sdk for both platforms via expect/actual) - but when i try to build and test it for iOS i receive error. did anyone face some issue and knows how to fix it?
    Landry Norris

    Landry Norris

    2 weeks ago
    How are you adding the dependency on iOS? Are you using cocoapods or cinterop on a framework? If you cinterop a framework, there’s a task you have to add that copies the frameworks to the iOS test binary.
    I have also seen similar when I use cocoapods in a module, but not for the main app module. In this case, the pods are never pulled down.
    b

    Bohdan

    2 weeks ago
    i was able to solve it
    Landry Norris

    Landry Norris

    2 weeks ago
    In case someone has a similar issue in the future, would you mind sharing how you solved the issue?
    b

    Bohdan

    2 weeks ago
    that works for me