Thread
#compose-wear
    a

    Ataul Munim

    3 weeks ago
    Is anyone developing on something other than a silicon based Mac & using the Wear emulator?
    John Nichol

    John Nichol

    2 weeks ago
    I do some of my work dev on Linux and occasional personal dev on Windows/Linux with the Wear Emulator. My Chromebook doesn't have the necessary h/w support to run the emulator sadly.
    y

    yschimke

    2 weeks ago
    Github CI obviously. Where the required mac instances are 10x the cost.
    a

    Ataul Munim

    2 weeks ago
    I was seeing crashes (observing another dev) on an x86 Wear emulator yesterday that seemed unrelated to the project, and no errors in logcat - when launching a tile or the app. Someone else had said they also had a similar experience when they were on an Intel based Mac (different project) but I'm unable to reproduce on my m1 so I was wondering if there's something wrong across the board with the x86 Wear emulator 🤔
    y

    Yingding Wang

    2 weeks ago
    Wear OS emulator on my Intel based Mac seems fine sofar. Got my M1 MBP will test ARM AVD for Wear OS prev 10 this week.
    a

    Ataul Munim

    2 weeks ago
    I wonder what's the issue then - there were more reports yday 🤔
    y

    Yingding Wang

    2 weeks ago
    I have run the ARM AVD Wear OS prev 10 emulator on M1 Max MBP, everything works well so far. It is worthwhile to mention I used the Zulu-11 Open JDK for AS, Gradle. I haven’t tested tile on ARM AVD yet. Might this a tile or maybe JDK related issue you are referring? Is there an issue ticket fired?
    a

    Ataul Munim

    2 weeks ago
    No, not yet because I haven't been able to reproduce it. So far, it's 2 people on Intel macs who get crashes when they try steps 1-4 on this codelab https://developer.android.com/codelabs/wear-tiles
    y

    Yingding Wang

    2 weeks ago
    I see, the codelab requires AS dolphin (RC1), I am still on chipmunk.