Going to <arrow-kt.io>, in specifically the page w...
# arrow
Going to arrow-kt.io, in specifically the page which shows the API for arrow core here (Don’t think the fact that it’s a reference to a specific method matters in this case) is literally nuking my Chrome browser, it becomes unresponsive for at least half a minute after trying to close the tab down 😅 And I am not even on a low end computer. I recently wrote a SOF comment with a link there here and I am afraid I’m gonna nuke their computer for whoever clicks it 😂 Is this something on your end or how the web page is generated or possibly only I am experiencing it? Asking here before I make a GH issue just to see if it’s only me who experiences it
Hi @Stylianos Gakis, this is automatically generated by dokka. There may be some config or custom rendering we may be able to do to make it easier. The better solution is to group those functions in sub packages but that would break imports. Maybe something we can address for 2.0.
Yeah I do think it’s a good idea going forward. But just to confirm, do you also get a very difficult experience when opening that specific link?
I don't but I'm on macbook M1 Max
so maybe not a good indicator for other machines seeing that page
I’m also on a M1 Max, that’s the problem 😅
Okay maybe it was a weird thing on my end and it may fix itself if I try again sometime in the future. So I guess don’t mind this, false alarm
The page is not doing anything weird for me in Safari, on a regular M1.
Yeah I do think it’s a good idea going forward.
Would you like to see
rather than
? I think it could help improve the API docs a lot, but not sure if it really improves UX 🤔 Such a change could be fairly easily addressed in 2.0, I am planning to write migration scripts for this kind of refactoring from 1.x.x to 2.0.0 since
by itself doesn't seem powerful enough for this.
Opened it again today and it did not struggle nearly as much, just a second or two and then it worked perfectly fine. It only froze my chrome tab when I tried to close it down. I feel like this is a me problem though, and not the docs itself somehow. So probably best not to base your decisions off of this. Yeah I don’t know discoverability-wise what would make the most sense. It’s true that the first place I searched for to find that function was arrow.core and not arrow.core.either.