Paul Woitaschek
08/28/2019, 7:46 AM[0..100]
, I might name the property proteinPercent
. Does that make sense? How would you name the property if it was in [0.0..1.0]
?darkmoon_uk
08/28/2019, 7:47 AM0.0..1.0
I would use dailyProteinIntakeRatio
0..100
- dailyProteinIntakePercent
Paul Woitaschek
08/28/2019, 7:50 AMdata class Goal(
val date: LocalDate,
val caloriesInKcal: Double,
val fatIntakeRatio : Double,
val proteinIntakeRatio : Double,
val carbIntakeRatio : Double,
val weightInKg: Double,
val waterInMl: Double,
val steps: Int
)
carb
is a typo. Is there a better abbreviation?wasyl
08/28/2019, 7:52 AMcarbs
complain as well?Paul Woitaschek
08/28/2019, 7:52 AMwasyl
08/28/2019, 7:58 AMcarb
is a word that suits you bestdarkmoon_uk
08/28/2019, 7:58 AMPaul Woitaschek
08/28/2019, 8:00 AMdarkmoon_uk
08/28/2019, 8:03 AMintegralDigitCount
and fractionalDigitCount
?wasyl
08/28/2019, 8:06 AMdecimal
for after the dotPaul Woitaschek
08/28/2019, 8:11 AMwasyl
08/28/2019, 8:12 AMEugen Martynov
08/28/2019, 11:30 AM