this looks terrible how can i refactor: ``` if (s...
# announcements
i
this looks terrible how can i refactor:
Copy code
if (state is EnterPassword) {
            hidePassword()
        } 
        eye_authentication_iv.visible =state is EnterPassword
d
I would just do minor adjustment:
Copy code
eye_authentication_iv.visible = state is EnterPassword

if (eye_authentication_iv.visible) {
    hidePassword()
}
i
OK thanks